GHSA-jpcm-4485-69p7HighCVSS 7.4

Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin

Published
March 9, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

The com.bmuschko:gradle-vagrant-plugin Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables.

When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors.

Patches

Fixed in version 3.0.0

References

  • https://github.com/bmuschko/gradle-vagrant-plugin/blob/292129f9343d00d391543fae06239e9b0f33db73/src/main/groovy/com/bmuschko/gradle/vagrant/process/GDKExternalProcessExecutor.groovy#L42-L44
  • https://github.com/bmuschko/gradle-vagrant-plugin/issues/19
  • https://github.com/bmuschko/gradle-vagrant-plugin/pull/20

For more information

If you have any questions or comments about this advisory:

🎯 Affected products1

  • maven/com.bmuschko:gradle-vagrant-plugin:>= 0.6, < 3.0.0

🔗 References (6)