GHSA-jp6r-xcjj-5h7rMediumCVSS 6.1
Cross-Site Scripting in cyberchef
🔗 CVE IDs covered (1)
📋 Description
Versions of cyberchef prior to 8.31.3 are vulnerable to Cross-Site Scripting. In Text Encoding Brute Force the table rows are created by concatenating the value variable unsanitized in the HTML code. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser.
Recommendation
Upgrade to version 8.31.3 or later.
🎯 Affected products1
- npm/cyberchef:< 8.31.3
🔗 References (8)
- https://nvd.nist.gov/vuln/detail/CVE-2019-15532
- https://github.com/gchq/CyberChef/commit/01f0625d6a177f9c5df9281f12a27c814c2d8bcf
- https://github.com/gchq/CyberChef/compare/v8.31.1...v8.31.2
- https://github.com/gchq/CyberChef/issues/539
- https://github.com/gchq/CyberChef/issues/544
- https://snyk.io/vuln/SNYK-JS-CYBERCHEF-460296
- https://www.npmjs.com/advisories/1149
- https://github.com/advisories/GHSA-jp6r-xcjj-5h7r