GHSA-jjmg-xmq2-g6ffMediumCVSS 4.8

Magento 2 Community Edition XSS Vulnerability

Published
May 24, 2022
Last Modified
February 12, 2024

🔗 CVE IDs covered (1)

📋 Description

A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

🎯 Affected products2

  • composer/magento/community-edition:>= 2.2.0, < 2.2.10
  • composer/magento/community-edition:>= 2.3, < 2.3.2-p2

🔗 References (7)