GHSA-jf85-cpcp-j695CriticalCVSS 9.1
Prototype Pollution in lodash
🔗 CVE IDs covered (1)
📋 Description
Versions of lodash before 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep allows a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects.
Recommendation
Update to version 4.17.12 or later.
🎯 Affected products5
- npm/lodash:< 4.17.12
- npm/lodash-es:< 4.17.14
- npm/lodash-amd:< 4.17.13
- npm/lodash.defaultsdeep:< 4.6.1
- rubygems/lodash-rails:< 4.17.12
🔗 References (11)
- https://github.com/lodash/lodash/pull/4336
- https://nvd.nist.gov/vuln/detail/CVE-2019-10744
- https://snyk.io/vuln/SNYK-JS-LODASH-450202
- https://access.redhat.com/errata/RHSA-2019:3024
- https://support.f5.com/csp/article/K47105354?utm_source=f5support&utm_medium=RSS
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://support.f5.com/csp/article/K47105354?utm_source=f5support&%3Butm_medium=RSS
- https://security.netapp.com/advisory/ntap-20191004-0005
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/lodash-rails/CVE-2019-10744.yml
- https://github.com/advisories/GHSA-jf85-cpcp-j695