GHSA-jcpv-g9rr-qxrcHighCVSS 7.5
Regular Expression Denial of Service in hawk
🔗 CVE IDs covered (1)
📋 Description
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
🎯 Affected products2
- npm/hawk:< 3.1.3
- npm/hawk:>= 4.0.0, < 4.1.1
🔗 References (8)
- https://nvd.nist.gov/vuln/detail/CVE-2016-2515
- https://github.com/hueniverse/hawk/issues/168
- https://github.com/advisories/GHSA-jcpv-g9rr-qxrc
- https://www.npmjs.com/advisories/77
- https://github.com/hueniverse/hawk/commit/0833f99ba64558525995a7e21d4093da1f3e15fa
- https://bugzilla.redhat.com/show_bug.cgi?id=1309721
- http://www.openwall.com/lists/oss-security/2016/02/20/1
- http://www.openwall.com/lists/oss-security/2016/02/20/2