GHSA-jccx-m9v4-9hwhHighCVSS 8.4
LoLLMS Code Injection vulnerability
🔗 CVE IDs covered (1)
📋 Description
A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. The vulnerability arises from the use of Python's eval() function to evaluate mathematical expressions within a Python sandbox that disables __builtins__ and only allows functions from the math module. This sandbox can be bypassed by loading the os module using the _frozen_importlib.BuiltinImporter class, allowing an attacker to execute arbitrary commands on the server. The issue is fixed in version 9.10.
🎯 Affected products1
- pip/lollms:< 11.0.0