GHSA-jc7h-c423-mpjcMediumCVSS 6.5
Apache Shiro vulnerable to path traversal
🔗 CVE IDs covered (1)
📋 Description
Apache Shiro before 1.130 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting
Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure blockSemicolon is enabled (this is the default).
🎯 Affected products2
- maven/org.apache.shiro:shiro-core:< 1.13.0
- maven/org.apache.shiro:shiro-core:>= 2.0.0alpha1, < 2.0.0alpha4