GHSA-j9xp-92vc-559jCriticalCVSS 9.8

SQL Injection in sequelize

Published
November 6, 2019
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

Affected versions of sequelize are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the MariaDB and MySQL dialects, which may allow attackers to inject SQL statements and execute arbitrary SQL queries.

Recommendation

If you are using sequelize 5.x, upgrade to version 5.8.11 or later. If you are using sequelize 4.x, upgrade to version 4.44.3 or later. If you are using sequelize 3.x, upgrade to version 3.35.1 or later.

🎯 Affected products3

  • npm/sequelize:< 3.35.1
  • npm/sequelize:>= 4.0.0, < 4.44.3
  • npm/sequelize:>= 5.0.0, < 5.8.11

🔗 References (6)