GHSA-j59f-6m4q-62h6HighCVSS 7.5Disclosed before NVD
Improper Key Verification in ipns
📋 Description
Versions 0.1.1 or 0.1.2 of ipns are vulnerable to improper key validation. This is due to the public key verification was not being performed properly, resulting in any key being valid.
Recommendation
Update to version 0.1.3 or later.
🎯 Affected products1
- npm/ipns:< 0.1.3