GHSA-j3mm-wmfm-mwvhMedium

Cross-site scripting (XSS) in the CKEditor 5 real-time collaboration package

Published
February 20, 2025
Last Modified
February 20, 2025

🔗 CVE IDs covered (1)

📋 Description

Impact

During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 real-time collaboration package. This vulnerability can lead to unauthorized JavaScript code execution and affects user markers, which represent users' positions within the document.

This vulnerability affects only installations with Real-time collaborative editing enabled.

Patches

The problem has been recognized and patched. The fix will be available in version 44.2.1 (and above).

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

🎯 Affected products2

  • npm/@ckeditor/ckeditor5-real-time-collaboration:>= 41.3.0, <= 44.2.0
  • npm/ckeditor5-premium-features:>= 42.0.0, < 44.2.0

🔗 References (6)