GHSA-hxqw-6qv7-cqfvHighCVSS 8.8

Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin

Published
March 23, 2026
Last Modified
March 25, 2026

🔗 CVE IDs covered (1)

📋 Description

Security Advisory — Code Study Plugin

Summary

An authenticated user may be able to execute arbitrary code in the Code Study Plugin.

Affected Versions

  • 1.x series: <= 1.41.0
  • 2.x series: <= 2.41.0

Patched Versions

  • 1.41.1
  • 2.41.1

Description

In the Code Study Plugin, an authenticated user could trigger unintended code execution. If exploited, it may lead to code execution on the server or information disclosure. Users affected by this vulnerability should update to a fixed version.

Solution

Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.

Credits

OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.

🎯 Affected products2

  • composer/opensource-workshop/connect-cms:< 1.41.1
  • composer/opensource-workshop/connect-cms:>= 2.0.0, < 2.41.1

🔗 References (6)