GHSA-hwch-749c-rv63CriticalCVSS 9.8

Potential Command Injection in hubot-scripts

Published
August 31, 2020
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions 2.4.3 and earlier of hubot-scripts are vulnerable to a command injection vulnerablity in the hubot-scripts/package/src/scripts/email.coffee module.

Mitigating Factors

The email script is not enabled by default, it has to be manually added to hubot's list of loaded scripts.

Recommendation

Update hubot-scripts to version 2.4.4 or later.

🎯 Affected products1

  • npm/hubot-scripts:<= 2.4.3

🔗 References (6)