GHSA-hv9c-qwqg-qj3vHighCVSS 8.1

Electron webPreferences vulnerability can be used to perform remote code execution

Published
August 23, 2018
Last Modified
January 11, 2023

🔗 CVE IDs covered (1)

📋 Description

GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a webPreferences vulnerability that can be leveraged to perform remote code execution.

More information to determine if you are impacted can be found on the electron blog.

Recommendation

Upgrade Electron to >=3.0.0-beta.7, >=2.0.8, >=1.8.8, or >=1.7.16.

🎯 Affected products4

  • npm/electron:>= 1.7.0, < 1.7.16
  • npm/electron:>= 1.8.0, < 1.8.8
  • npm/electron:>= 2.0.0, < 2.0.8
  • npm/electron:>= 3.0.0-beta.1, < 3.0.0-beta.7

🔗 References (10)