GHSA-hpcf-8vf9-q4gjMediumCVSS 6.1

jQuery-UI vulnerable to Cross-site Scripting in dialog closeText

Published
October 24, 2017
Last Modified
September 26, 2023

🔗 CVE IDs covered (1)

📋 Description

Affected versions of jquery-ui are vulnerable to a cross-site scripting vulnerability when arbitrary user input is supplied as the value of the closeText parameter in the dialog function.

jQuery-UI is a library for manipulating UI elements via jQuery.

Version 1.11.4 has a cross site scripting (XSS) vulnerability in the closeText parameter of the dialog function. If your application passes user input to this parameter, it may be vulnerable to XSS via this attack vector.

Recommendation

Upgrade to jQuery-UI 1.12.0 or later.

🎯 Affected products4

  • npm/jquery-ui:< 1.12.0
  • rubygems/jquery-ui-rails:< 6.0.0
  • maven/org.webjars.npm:jquery-ui:< 1.12.0
  • nuget/jQuery.UI.Combined:< 1.12.0

🔗 References (39)