GHSA-h8hx-2c5r-32cfHighCVSS 8.1

Cross-Site Request Forgery (CSRF) in trestle-auth

Published
April 13, 2021
Last Modified
May 4, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials.

Patches

The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.

For more information

If you have any questions or comments about this advisory:

🎯 Affected products1

  • rubygems/trestle-auth:>= 0.4.0, < 0.4.2

🔗 References (6)