GHSA-h77r-rp97-7rv4HighCVSS 7.5

Privilage Escalation in moodle

Published
March 29, 2021
Last Modified
September 12, 2023

🔗 CVE IDs covered (1)

📋 Description

In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

🎯 Affected products4

  • composer/moodle/moodle:>= 3.9.0, < 3.9.3
  • composer/moodle/moodle:>= 3.8.0, < 3.8.6
  • composer/moodle/moodle:>= 3.7.0, < 3.7.9
  • composer/moodle/moodle:>= 3.5, < 3.5.15

🔗 References (7)