GHSA-h6q6-9hqw-rwfvMediumCVSS 4.3

Misinterpretation of malicious XML input

Published
March 12, 2021
Last Modified
February 2, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents.

This may lead to unexpected syntactic changes during XML processing in some downstream applications.

Patches

Update to 0.5.0 (once it is released)

Workarounds

Downstream applications can validate the input and reject the maliciously crafted documents.

References

Similar to this one reported on the Go standard library:

  • https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/

For more information

If you have any questions or comments about this advisory:

  • Open an issue in xmldom/xmldom
  • Email us: send an email to all addresses that are shown by npm owner ls xmldom

🎯 Affected products1

  • npm/xmldom:< 0.5.0

🔗 References (7)