GHSA-h2p3-h48h-9jj7CriticalCVSS 9.8
PIDUsage Enables OS Command Injection
🔗 CVE IDs covered (1)
📋 Description
Overview
Affected versions of pidusage pass unsanitized input to child_process.exec(), resulting in arbitrary code execution in the ps method.
This package is vulnerable to this PoC on Darwin, SunOS, FreeBSD, and AIX.
Windows and Linux are not vulnerable.
Proof of Concept
var pid = require('pidusage');
pid.stat('1 && /usr/local/bin/python');
Remediation
Update to version 1.1.5 or later.
🎯 Affected products1
- npm/pidusage:<= 1.1.4