GHSA-h24f-9mm4-w336MediumCVSS 6.1
Cross-site Scripting (XSS) - Stored in crud-file-server
🔗 CVE IDs covered (1)
📋 Description
Versions of crud-file-server before 0.8.0 are vulnerable to stored cross-site scripting (XSS). This is due to insufficient santiziation of filenames when directory index is served by crud-file-server.
Recommendation
Update to version 0.8.0 or later.
🎯 Affected products1
- npm/crud-file-server:<= 0.7.0