GHSA-gxpj-cx7g-858cLowCVSS 3.7

Regular Expression Denial of Service in debug

Published
August 9, 2018
Last Modified
March 25, 2024

🔗 CVE IDs covered (1)

📋 Description

Affected versions of debug are vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter.

As it takes 50,000 characters to block the event loop for 2 seconds, this issue is a low severity issue.

This was later re-introduced in version v3.2.0, and then repatched in versions 3.2.7 and 4.3.1.

Recommendation

Version 2.x.x: Update to version 2.6.9 or later. Version 3.1.x: Update to version 3.1.0 or later. Version 3.2.x: Update to version 3.2.7 or later. Version 4.x.x: Update to version 4.3.1 or later.

🎯 Affected products4

  • npm/debug:< 2.6.9
  • npm/debug:>= 3.0.0, < 3.1.0
  • npm/debug:>= 3.2.0, < 3.2.7
  • npm/debug:>= 4.0.0, < 4.3.1

🔗 References (11)