GHSA-gx69-6cp4-hxrjHighCVSS 7.5

RubyGems Link Following vulnerability

Published
May 13, 2022
Last Modified
March 9, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

🎯 Affected products2

  • rubygems/rubygems-update:< 2.7.6
  • maven/org.jruby:jruby-stdlib:< 9.1.16.0

🔗 References (19)