GHSA-gjph-xf5q-6mfqHighDisclosed before NVD

Denial of Service in @hapi/ammo

Published
September 3, 2020
Last Modified
January 9, 2023

📋 Description

Versions of @hapi/ammo prior to 3.1.2 or 5.0.1 are vulnerable to Denial of Service. The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to version 3.1.2 or 5.0.1.

🎯 Affected products2

  • npm/@hapi/ammo:< 3.1.2
  • npm/@hapi/ammo:>= 4.0.0, < 5.0.1

🔗 References (2)