GHSA-gcqf-f89c-68hvMediumCVSS 4.5

Hashicorp Vault Community vulnerable to Generation of Error Message Containing Sensitive Information

Published
May 2, 2025
Last Modified
May 6, 2025

🔗 CVE IDs covered (1)

📋 Description

Vault Community and Vault Enterprise Key/Value (kv) Version 2 plugin may unintentionally expose sensitive information in server and audit logs when users submit malformed payloads during secret creation or update operations via the Vault REST API. This vulnerability, identified as CVE-2025-4166, is fixed in Vault Community 1.19.3 and Vault Enterprise 1.19.3, 1.18.9, 1.17.16, 1.16.20.

🎯 Affected products1

  • go/github.com/hashicorp/vault:>= 0.3.0, < 1.19.3

🔗 References (4)