GHSA-g74r-ffvr-5q9fMediumDisclosed before NVD
Memory Exposure in concat-stream
📋 Description
Versions of concat-stream before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into write()
Versions <1.3.0 are not affected due to not using unguarded Buffer constructor.
Recommendation
Update to version 1.5.2, 1.4.11, 1.3.2 or later.
If you are unable to update make sure user provided input into the write() function is not a number.
🎯 Affected products3
- npm/concat-stream:>= 1.5.0, < 1.5.2
- npm/concat-stream:>= 1.4.0, < 1.4.11
- npm/concat-stream:>= 1.3.0, < 1.3.2