GHSA-g5hv-r743-v8pmHighCVSS 8.8

Apache Airflow has DAG Author Code Execution possibility in airflow-scheduler

Published
July 17, 2024
Last Modified
January 21, 2025

🔗 CVE IDs covered (1)

📋 Description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

🎯 Affected products1

  • pip/apache-airflow:>= 2.4.0, < 2.9.3

🔗 References (7)