GHSA-fv4g-gwpj-74grLowCVSS 7.5

Path traversal vulnerability in stripe-cli

Published
September 5, 2024
Last Modified
November 18, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

A vulnerability exists in stripe-cli versions 1.11.1 and higher where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files.

The update addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path.

There has been no evidence of exploitation of this vulnerability.

Recommendation

Upgrade to stripe-cli v1.21.3.

Acknowledgements

Thank you to 0xacb and bordiez for reporting this vulnerability.

For more information

Email us at [email protected]

🎯 Affected products1

  • go/github.com/stripe/stripe-cli:>= 1.11.1, < 1.21.3

🔗 References (3)