GHSA-fr32-gr5c-xq5cHighCVSS 7.5

RubyGems Escape sequence injection vulnerability in verbose

Published
June 20, 2019
Last Modified
August 28, 2023

🔗 CVE IDs covered (1)

📋 Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.

🎯 Affected products2

  • rubygems/rubygems-update:>= 2.6.0, < 2.7.9
  • rubygems/rubygems-update:>= 3.0.0, < 3.0.2

🔗 References (6)