GHSA-fq54-2j52-jc42HighCVSS 7.5

Next.js Denial of Service (DoS) condition

Published
July 10, 2024
Last Modified
November 6, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server.

This vulnerability can affect all Next.js deployments on the affected versions.

Patches

This vulnerability was resolved in Next.js 13.5 and later. We recommend that users upgrade to a safe version.

Workarounds

There are no official workarounds for this vulnerability.

Credit

  • Thai Vu of flyseccorp.com
  • Aonan Guan (@0dd), Senior Cloud Security Engineer

🎯 Affected products1

  • npm/next:>= 13.3.1, < 13.5.0

🔗 References (3)