GHSA-fgh3-pwmp-3qw3CriticalCVSS 9.8

Apache Inlong Deserialization of Untrusted Data vulnerability

Published
May 8, 2024
Last Modified
February 11, 2025

🔗 CVE IDs covered (1)

📋 Description

Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.7.0 through 1.11.0. The attackers can bypass using malicious parameters.

Users are advised to upgrade to Apache InLong's 1.12.0 or cherry-pick [1], [2] to solve it.

[1] https://github.com/apache/inlong/pull/9694

[2]  https://github.com/apache/inlong/pull/9707

🎯 Affected products1

  • maven/org.apache.inlong:manager-pojo:>= 1.7.0, < 1.12.0

🔗 References (8)