GHSA-f73h-224c-62qrHighCVSS 7.2

Magento Server-Side Request Forgery (SSRF)

Published
May 24, 2022
Last Modified
February 12, 2024

🔗 CVE IDs covered (1)

📋 Description

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to manipulate shippment settings can execute arbitrary code through server-side request forgery due to unsafe handling of a carrier gateway.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

🎯 Affected products2

  • composer/magento/community-edition:>= 2.2.0, < 2.2.10
  • composer/magento/community-edition:>= 2.3.0, < 2.3.2-p2

🔗 References (4)