GHSA-f6m8-qm7j-fh65HighCVSS 7.3

Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability

Published
October 2, 2025
Last Modified
November 5, 2025

🔗 CVE IDs covered (1)

📋 Description

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

🎯 Affected products7

  • maven/org.apache.kylin:kylin:>= 4.0.0, < 5.0.3
  • maven/org.apache.kylin:kylin-common-server:>= 4.0.0, < 5.0.3
  • maven/org.apache.kylin:kylin-common-service:>= 4.0.0, < 5.0.3
  • maven/org.apache.kylin:kylin-core-common:>= 4.0.0, < 5.0.3
  • maven/org.apache.kylin:kylin-core-metadata:>= 4.0.0, < 5.0.3
  • maven/org.apache.kylin:kylin-ops-server:>= 4.0.0, < 5.0.3
  • maven/org.apache.kylin:kylin-server:>= 4.0.0, < 5.0.3

🔗 References (7)