GHSA-f5r8-7h4f-jr9xHighCVSS 8.8

Moodle incorrect access control

Published
May 24, 2022
Last Modified
August 23, 2023

🔗 CVE IDs covered (1)

📋 Description

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

🎯 Affected products4

  • composer/moodle/moodle:>= 3.9, <= 3.9.1
  • composer/moodle/moodle:>= 3.8, <= 3.8.4
  • composer/moodle/moodle:>= 3.7, <= 3.7.7
  • composer/moodle/moodle:>= 3.5, <= 3.5.13

🔗 References (3)