GHSA-f4rq-f4j9-f6rmCriticalCVSS 9.8

Apache IoTDB Vulnerable to Remote Code Execution

Published
May 14, 2025
Last Modified
July 2, 2025

🔗 CVE IDs covered (1)

📋 Description

Remote Code Execution with untrusted URI of UDF vulnerability in Apache IoTDB. The attacker who has privilege to create UDF can register malicious function from untrusted URI.

This issue affects Apache IoTDB: from 1.0.0 before 1.3.4.

Users are recommended to upgrade to version 1.3.4, which fixes the issue.

🎯 Affected products2

  • maven/org.apache.iotdb:iotdb-core:>= 1.0.0, < 1.3.4
  • pip/apache-iotdb:>= 1.0.0, < 1.3.4

🔗 References (6)