GHSA-cx8m-8xmx-q8v3CriticalCVSS 9.1
Denial of Service in memjs
🔗 CVE IDs covered (1)
📋 Description
Versions of memjs prior to 1.2.2 are vulnerable to Denial of Service (DoS). The package fails to sanitize the value option passed to the Buffer constructor, which may allow attackers to pass large values exhausting system resources.
Recommendation
Upgrade to version 1.2.2 or later.
🎯 Affected products1
- npm/memjs:<= 1.2.0