GHSA-cj2h-ww36-v932HighCVSS 9.8

Improper Certificate Validation in HashiCorp Nomad

Published
May 18, 2021
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

🎯 Affected products1

  • go/github.com/hashicorp/nomad:< 0.10.3

🔗 References (5)