GHSA-cg54-gpgr-4rm6HighCVSS 7.9
user-readable api tokens in systemd units for JupyterHub
🔗 CVE IDs covered (1)
📋 Description
Impact
user API tokens issued to single-user servers are specified in the environment of systemd units, which are accessible to all users.
In particular, the-littlest-jupyterhub is affected, which uses systemdspawner by default.
Patches
Patched in jupyterhub-systemdspawner v0.15
Workarounds
No workaround other than upgrading systemdspawner to 0.15
For more information
If you have any questions or comments about this advisory:
- Open a thread in the Jupyter forum
- Email us at [email protected]
🎯 Affected products1
- pip/jupyterhub-systemdspawner:< 0.15.0
🔗 References (7)
- https://github.com/jupyterhub/systemdspawner/security/advisories/GHSA-cg54-gpgr-4rm6
- https://github.com/jupyterhub/systemdspawner/commit/a4d08fd2ade1cfd0ef2c29dc221e649345f23580
- https://github.com/jupyterhub/systemdspawner/blob/master/CHANGELOG.md#v015
- https://nvd.nist.gov/vuln/detail/CVE-2020-26261
- https://github.com/pypa/advisory-database/tree/main/vulns/jupyterhub-systemdspawner/PYSEC-2020-52.yaml
- https://pypi.org/project/jupyterhub-systemdspawner
- https://github.com/advisories/GHSA-cg54-gpgr-4rm6