GHSA-c866-8gpw-p3mvHighCVSS 7.7

HashiCorp Nomad vulnerable to symlink attacks

Published
February 8, 2024
Last Modified
September 26, 2024

🔗 CVE IDs covered (1)

📋 Description

HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. Fixed in Nomad 1.7.4, 1.6.7, 1.5.14.

🎯 Affected products3

  • go/github.com/hashicorp/nomad:= 1.5.13
  • go/github.com/hashicorp/nomad:>= 1.6.0, <= 1.6.6
  • go/github.com/hashicorp/nomad:= 1.7.3

🔗 References (7)