GHSA-c75v-2vq8-878fMediumCVSS 5.4

Angular vulnerable to Cross-site Scripting

Published
May 27, 2022
Last Modified
November 20, 2025

🔗 CVE IDs covered (1)

📋 Description

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.

🎯 Affected products3

  • npm/@angular/core:>= 11.1.0-next.0, <= 11.1.0-next.2
  • npm/@angular/core:>= 11.0.0, < 11.0.5
  • npm/@angular/core:< 10.2.5

🔗 References (8)