GHSA-c72g-53hw-82q7Medium

OpenFGA Authorization Bypass

Published
May 23, 2025
Last Modified
March 30, 2026

🔗 CVE IDs covered (1)

📋 Description

Overview

OpenFGA v1.8.0 to v1.8.12 ( openfga-0.2.16 <= Helm chart <= openfga-0.2.31, v1.8.0 <= docker <= v.1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed.

Am I Affected?

If you are using OpenFGA v1.8.0 to v1.8.12, specifically under the following conditions, you are affected by this authorization bypass vulnerability:

Fix

Upgrade to v1.8.13. This upgrade is backwards compatible.

Acknowledgments

OpenFGA would like to thank @udyvish for discovering this vulnerability.

🎯 Affected products1

  • go/github.com/openfga/openfga:>= 1.8.0, < 1.8.13

🔗 References (5)