GHSA-c52f-pq47-2r9jLowCVSS 3.0

plugin.yaml file allows for duplicate entries in helm

Published
May 24, 2021
Last Modified
May 29, 2025

🔗 CVE IDs covered (1)

📋 Description

Impact

During a security audit of Helm's code base, Helm maintainers identified a bug in which a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack.

To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection).

Patches

This issue has been patched in Helm 2.16.11 and Helm 3.3.2.

Workarounds

Make sure to install plugins using a secure connection protocol like SSL.

🎯 Affected products2

  • go/helm.sh/helm/v3:>= 3.0.0, < 3.3.2
  • go/helm.sh/helm:>= 2.0.0, < 2.16.11

🔗 References (9)