GHSA-c2h3-6mxw-7mvqMediumCVSS 5.9

Insufficiently restricted permissions on plugin directories

Published
October 4, 2021
Last Modified
January 31, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files.

Patches

This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability.

Workarounds

Limit access to the host to trusted users. Update directory permission on container bundles directories.

For more information

If you have any questions or comments about this advisory:

🎯 Affected products2

  • go/github.com/containerd/containerd:< 1.4.11
  • go/github.com/containerd/containerd:>= 1.5.0, < 1.5.7

🔗 References (13)