GHSA-c2f4-cvqm-65w2MediumCVSS 5.9

Puma HTTP Request/Response Smuggling vulnerability

Published
January 8, 2024
Last Modified
November 4, 2025

🔗 CVE IDs covered (1)

📋 Description

Impact

Prior to versions 6.4.2 and 5.6.8, puma exhibited dangerous behavior when parsing chunked transfer encoding bodies.

Fixed versions limit the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption.

Patches

The vulnerability has been fixed in 6.4.2 and 5.6.8.

Workarounds

No known workarounds.

References

🎯 Affected products2

  • rubygems/puma:>= 6.0.0, < 6.4.2
  • rubygems/puma:< 5.6.8

🔗 References (8)