GHSA-9xg9-hh45-xcm6CriticalCVSS 9.8

Apache InLong Manager Remote Code Execution vulnerability

Published
January 3, 2024
Last Modified
February 13, 2025

🔗 CVE IDs covered (1)

📋 Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.This issue affects Apache InLong: from 1.5.0 through 1.9.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.10.0 or cherry-pick [1] to solve it.

[1] https://github.com/apache/inlong/pull/9329

🎯 Affected products1

  • maven/org.apache.inlong:manager-pojo:>= 1.5.0, < 1.10.0

🔗 References (6)