GHSA-9w7f-m4j4-j3xwCriticalCVSS 9.8
Gerapy may cause remote code execution
🔗 CVE IDs covered (1)
📋 Description
Impact
project_configure function exist remote code execute in Gerapy < 0.9.8
Patches
Patched in version 0.9.8, please install with:
pip3 install -U gerapy
🎯 Affected products1
- pip/gerapy:< 0.9.8
🔗 References (8)
- https://github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw
- https://nvd.nist.gov/vuln/detail/CVE-2021-43857
- https://github.com/Gerapy/Gerapy/issues/219
- https://github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28
- http://packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.html
- https://github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2022-228.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2021-867.yaml
- https://github.com/advisories/GHSA-9w7f-m4j4-j3xw