GHSA-9w38-p64v-xpmvMediumCVSS 6.5

Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree

Published
March 21, 2024
Last Modified
February 13, 2025

🔗 CVE IDs covered (1)

📋 Description

This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' calling 'ListDelimiterHandler.flatten(Object, int)' with a cyclical object tree. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

🎯 Affected products1

  • maven/org.apache.commons:commons-configuration2:>= 2.0, < 2.10.1

🔗 References (8)