GHSA-9v62-24cr-58cxMediumCVSS 5.9Disclosed before NVD
Denial of Service in node-sass
📋 Description
Affected versions of node-sass are vulnerable to Denial of Service (DoS). Crafted objects passed to the renderSync function may trigger C++ assertions in CustomImporterBridge::get_importer_entry and CustomImporterBridge::post_process_return_value that crash the Node process. This may allow attackers to crash the system's running Node process and lead to Denial of Service.
Recommendation
Upgrade to version 4.13.1 or later
🎯 Affected products1
- npm/node-sass:>= 3.3.0, < 4.13.1