GHSA-9qvm-2vhf-q649Medium
RubyGems Regular Expression Denial of Service
🔗 CVE IDs covered (1)
📋 Description
Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.
🎯 Affected products4
- rubygems/rubygems-update:< 1.8.23.2
- rubygems/rubygems-update:>= 1.8.24, < 1.8.27
- rubygems/rubygems-update:>= 2.0.0, < 2.0.10
- rubygems/rubygems-update:>= 2.1.0, < 2.1.5
🔗 References (8)
- https://nvd.nist.gov/vuln/detail/CVE-2013-4363
- http://blog.rubygems.org/2013/09/24/CVE-2013-4363.html
- http://www.openwall.com/lists/oss-security/2013/09/14/3
- http://www.openwall.com/lists/oss-security/2013/09/18/8
- http://www.openwall.com/lists/oss-security/2013/09/20/1
- https://web.archive.org/web/20170331150441/https://puppet.com/security/cve/cve-2013-4363
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2013-4363.yml
- https://github.com/advisories/GHSA-9qvm-2vhf-q649