GHSA-9p2w-rmx4-9mw7HighCVSS 7.2

Command Injection in strapi

Published
September 4, 2020
Last Modified
December 29, 2025

🔗 CVE IDs covered (1)

📋 Description

Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.

Recommendation

Upgrade to version 3.0.0-beta.17.8 or later

🎯 Affected products1

  • npm/strapi:<= 3.0.0-beta.17.7

🔗 References (7)