GHSA-9j7m-rjqx-48vhMedium

RubyGems Regular Expression Denial of Service vulnerability

Published
May 14, 2022
Last Modified
August 16, 2023

🔗 CVE IDs covered (1)

📋 Description

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

🎯 Affected products4

  • rubygems/rubygems-update:< 1.8.23.1
  • rubygems/rubygems-update:>= 1.8.24, < 1.8.26
  • rubygems/rubygems-update:>= 2.0.0, < 2.0.8
  • rubygems/rubygems-update:>= 2.1.0.rc.1, < 2.1.0

🔗 References (16)