GHSA-9gp7-jvm2-r4mxMediumCVSS 5.9

Apache Struts Improper Input Validation vulnerability

Published
October 16, 2018
Last Modified
January 4, 2024

🔗 CVE IDs covered (1)

📋 Description

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

🎯 Affected products1

  • maven/org.apache.struts:struts2-core:>= 2.5.0, < 2.5.12

🔗 References (8)